Trouble flashing v1 hardware to current firmware

My v1 hardware w/ wi-fi is currently running firmware version 2.2.3 and I'm trying to update to 2.3.5 so I can migrate to the new SmartThings app and over-the-air updates through the Konnected app. I'm following the flashing instructions at the link provided, but the Flash Tool times out after only displaying this message:

Connecting........_____....._____....._____....._____....._____....._____....._____....._____....._____....._____

I've refreshed the com port to verify I'm choosing the correct one.
Here are the instructions I'm following:
https://help.konnected.io/support/solutions/articles/32000023470-flashing-konnected-firmware-software

Any help would be appreciated!

  • Same exact problem, I opened a ticket as I've been having a lot of issues with the primary and add-on card.  Opened up a ticket and got an email from andy, and I replied back with a number of the issues I'm having, but no reply and then they just closed by ticket.  Thought I would try updating the firmware today as I saw the same thing you saw, but I just get the connecting...._____ message too.

  • @Mike,

    Sorry, I'm not much help here on actually fixing the problem. Konnected's recommendation to me was to purchase a replacement wi-fi module that came pre-loaded with the current firmware. Since it was $9 on clearance, I did that and it did solve my problem. Slightly disappointing that the fix cost me anything, but my system is working again. You can find the part here:
    https://konnected.io/collections/clearance/products/nodemcu-wifi-module

  • @Mike, the solution Konnected ended up recommending -- which worked, though it cost me a few bucks -- was to purchase a replacement wi-fi module that came pre-loaded with current firmware. Luckily it was on clearance for $9.

    https://konnected.io/collections/clearance/products/nodemcu-wifi-module

  • I was able to flash my v.1 with Windows 10 using the NodeMCU drivers. All seemed to work well, except no devices have shown up in the ST app. Connected Cloud is set up and shows up in the ST app.
Login or Signup to post a comment