Smart Home Monitor not triggering alarm

Have a weird issue where Konnected devices are showing as open/close in Smartthings but are not triggering the Smart Home Monitor alarm.

Using NodeMCU boards (tested 2 different boards).  Just updated to latest firmware.

Tested a door & window (on different boards) while system was armed away and armed stay.  Both door and window did not trigger the alarm.  Both door and window did register as open/close with Smartthings.  I also have automations/virtual switches to create a sound on the amazon dots and that is working as expected.

If I trigger a window that is using a contact sensor, then the alarm triggers successfully.


As I mentioned above, I have updated to latest firmware.  I have verified/reconnected Smarthings to KonnectedCloud.  Everything should be working, and it was in the past, but I do not know when it stopped.  Happened to catch it when I was replacing batteries in the contact sensors and the alarm triggered.

I have verified that the Konnected sensors are configured to be used by Smart Home Monitor.  Even tried removing/readding them.


I don't think it would be related to a NodeMCU issue since I am talking to the cloud successfully.  Want to get this working correctly before I upgrade to the newer hardware for my house and my son's new condo.

  • Resolved. 


    Issue was a corrupt STHM configuration somehow.

    I ended up deleting STHM and rebooting hub.  Reinstalled STHM and everything now works as expected.  Just have to rebuild automations that used alarm state.

Login or Signup to post a comment