Failed to set up - Error setting up entry Konnected Alarm Panel for konnected

I can’t seem to connect my new Konnected board to home assistant. Logger: homeassistant.config_entries Source: components/konnected/panel.py:357 First occurred: 16:07:05 (3 occurrences) Last logged: 16:52:40 Error setting up entry Konnected Alarm Panel for konnected Traceback (most recent call last): File "/usr/src/homeassistant/homeassistant/config_entries.py", line 372, in async_setup result = await component.async_setup_entry(hass, self) File "/usr/src/homeassistant/homeassistant/components/konnected/__init__.py", line 260, in async_setup_entry await client.async_connect() File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 133, in async_connect await self.async_sync_device_config() File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 378, in async_sync_device_config != self.async_current_settings_payload() File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 356, in async_current_settings_payload "sensors": [ File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 357, in {self.api_version: s[self.api_version]} KeyError: 'pin' I’m running home assistant in docker on a debian laptop. HA and Konnected board on latest firmware. I can set the board up to run on Konnected cloud and Smartthings and Home Assistant detects it as a new device. I ran through the configuration and can’t get any further. I just get the error above. I’ve tried disconnecting from Smartthings and Deactivated Konnected Cloud as I am only interested in running it through HA. It as third party equivalent board based on NodeMCU. Any ideas?
  • I have same issue!


    I was not able to integrate it ether:


    Logger: homeassistant.config_entries

    Source: components/konnected/panel.py:359 

    First occurred: 9:30:38 PM (4 occurrences) 

    Last logged: 9:46:35 PM


    Error setting up entry Konnected Alarm Panel for konnected

    Traceback (most recent call last):

      File "/usr/src/homeassistant/homeassistant/config_entries.py", line 382, in async_setup

        result = await component.async_setup_entry(hass, self)

      File "/usr/src/homeassistant/homeassistant/components/konnected/__init__.py", line 260, in async_setup_entry

        await client.async_connect()

      File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 133, in async_connect

        await self.async_sync_device_config()

      File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 380, in async_sync_device_config

        != self.async_current_settings_payload()

      File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 358, in async_current_settings_payload

        "sensors": [

      File "/usr/src/homeassistant/homeassistant/components/konnected/panel.py", line 359, in <listcomp>

        {self.api_version: s[self.api_version]}

    KeyError: 'pin'

  • I ended up factory testing the board by doing a firmware update. Disconnecting from smarthings and Konnected cloud. Deleting the board from the app. I then started fresh, adding the board in the app, setting up the WiFi and doing nothing else in the app. Then went to home assistant, it was auto detected, configured the board and it worked.
  • It seems the only difference is that you have not configured zones or registered board with Konnected cloud. Once you configured via HA did it work in Konnected cloud and ST?
  • Haven't risked it as I only intended to use it with HA.
Login or Signup to post a comment