Napco Gemini GEM-RP8 Remote Arming/Disarming Issues With Home Assistant Integration

Hoping someone here might have a solution to my problem.

I was successfully able to interface the Konnected Alarm Panel Pro with my old Napco Gemini GEM-RP8 Alarm System. I've connected it to Home Assistant and I can see when my sensors are triggered. (Yay!)

The issue I am running into is setting up the Keyswitch to trigger arming/disarming the alarm remotely. The alarm manuals say that a keyswitch can be connected to zone 6 to arm and disarm it. I've connected zone 6 to the relays and then to the Alarm Panel Pro. I think I was able to program the keypad to turn on Keyswitch as well.

For some reason, when I activate the alarm via Home Assistant, it just beeps and shows Zone 6. Now from my understanding, this means the alarm system thinks the zone is open, but if the keyswitch is on, shouldn't it trigger arming? Not sure if I am missing something during programming. I can't figure out if Zone 6 has to be designated as a keyswitch or it does it automatically.

Any help would be much appreciated!

IMG4756.jpg
(1.58 MB)
  • Just to keep this thread updated for others who might be in my situation. I was able to get the system to arm remotely!


    Here is all the documentation on how to program the Napco Gemini GEM-RP8:

    You will want to make sure you enable the Momentary Keyswitch in program 26 on the Napco Alarm Panel. Wire the relay on the Konnected integration board to zone 6. 


    Once you set up Home Assistant, you will want to set Output 2 to switchable output. To get it to arm the system, you have to set the pulse duration to 1000ms and duration between pulses to 1000ms. This triggers the arming.


    If you want to be able to arm a "Home" mode, you will need to program your motion sensors as a delay zone in program 01.


    Still trying to figure out how to monitor the alarm status using the programmable outputs. Will update with more info if I figure it out.

  • "You will want to make sure you enable the Momentary Keyswitch in program 26 on the Napco Alarm Panel. Wire the relay on the Konnected integration board to zone 6. "


    Can you explain how you did this?  I have the 1632 panel also with the RP1 keypad.  Looked through the instructions with no luck.


    "Once you set up Home Assistant, you will want to set Output 2 to switchable output. To get it to arm the system, you have to set the pulse duration to 1000ms and duration between pulses to 1000ms. This triggers the arming."


    I did all this successfully but hitting the switch doesnt arm, I think I need to figure out that programming part you did above...can you provide any further details?

  • Hey Marc,


    Been a while since I had to do this so these instructions may not be perfect. If there are issues refer to the details in the PDF linked below. To enable the Momentary Keyswitch in program 26 you will need to put the panel into dealer program mode.  You will need to know the dealer code. Usually, they keep the default so try 4567.


    https://www.homecontrols.com/homecontrols/products/pdfs/NP-Napco/NPGEMP801_Programming_Instructions.pdf



    To enter the dealer program mode:

    Press [Function] ->  [8A] -> [enter dealer code](4567) -> [On/Off]


    To enter program 26:

    Press [Reset] -> [2] -> [6]


    You should now be in program 26. On the display, if you DO see a 1 that means the Momentary Keyswitch is enabled and you have some other issue in your setup. If you DO NOT see a 1 that means you need to enable Momentary Keyswitch.


    To enable the Momentary Keyswitch:

    Press [1]


    Zone 1 should now be lit up and the Momentary Keyswitch enabled.


    To exit dealer program mode:

    Press [Reset] -> [Function] ->  [8A] -> [enter dealer code](4567) -> [On/Off]


    Hope these instructions work for you. Good luck on your setup!

  • Thanks so much for that, looks like you have the GEM-P801.  I have the GEM-RP1.


    The programming looks to be completely different.


    If you want a laugh, take a look at the programming instructions for that one!  I cant make heads or tails of it!


    GEM-P3200_RP1_WI818G.17_PROG.pub (psgincnj.com)

  • So I think I understand this a little better.  Zone doubling makes this VERY difficult.


    I activated keyswitch arming on Zone 6.   Zone 6 shares the same terminals as Zone 14 (doubling).  Each zone uses a different resistor and thats apparently how the panel knows the difference.


    I de-activated Zone 14 (wont work if those terminals are set up as a keyswitch), and connected the Konnected relay to those terminals.


    Now when I trip the relay, It beeps and says  it cant arm due to a fault (meaning an open zone).  I also cannot manually arm the system.  Im assuming this is because zone 6 is open since I disconnected those wires and replaced them with the Konnected relay ones.


    If I de-activate Zone 6, I can manually arm the system, but when I trip the relay nothing happens.  Im assuming this is because I de-activated Zone 6 and this somehow makes the keyswitch arm not work.


    So I dont know how to proceed.  If I keep Zone 6 de-activated the relay keyswitch option doesnt seem to work, and if I keep it active, it works but I cant arm due to the open zone.


    Any ideas out there?  Maybe I'm missing something?


    GEM-P1632_WI808F.44_INSTALL.pub (napcosecurity.com)

    GEM-P1632_WI897E_PROGRAM.pdf (avss.net)



  • Hey Marc,


    If you had a resistor attached to the zone previously you might need to include it when you attach the Konnected board. When I set up mine I had to do the same.


    Best,

    Steven

Login or Signup to post a comment