Hi all,

I have searched the forums, but cannot find an answer for my exact scenario.

I am in the process of converting to a Konnected Pro panel from my existing and functioning CPI security system.  After some troubleshooting, I have successfully added door sensors and glass break to my Home Assistant integration, and I see the proper responses when triggered.  However, I have hit the wall converting the smoke alarms.  I think I simply don't know enough about the current wiring, and I'm not sure how to figure that out.

I have several Kidde Smoke Alarms (model i12060A) that are all wired together in my 2007 build home.  From the best I can tell, these are wired into my existing CPI panel with a total of 4 wires (red, black, green, yellow).  Two wires into zone and ground (red and black), and the other two wires are connected to "BUS" A and B (green and yellow, I am assuming this is power?).  This color scheme does not match any of the other zones, as normally the red and black are connected to power.  Anywho. . .  I am unsure if there is a relay already inline, and not sure where it would be, honestly.

I simply disconnected the zone pair (red and black) and connected them to the desired zone on my Konnected Pro panel.  Went through the integration configuration in Home Assistant, setting it as a binary/smoke sensor.  I cannot get any response on my home assistant front end.  When testing the alarms by pressing the test button, all alarms respond.  Not sure if that helps.

I am truly stumped and not sure how to proceed.  Any help or ideas on how to troubleshoot are greatly appreciated.


Login or Signup to post a comment