No alarm_control_panel entity in Home Assistant

I have a new Alarm Panel Pro that I have wired up, using Home Assistant 2021.1.4.  I added the integration and configured my zones, and the sensors are working correctly in Home Assistant.  However, I'm now trying to add an alarm panel (https://www.home-assistant.io/lovelace/alarm-panel/) to be able to arm/disarm, and it says that the entity_id of a device in the alarm_control_panel domain is required.  However, Konnected has only created the sensor entities, but not the alarm_control_panel.  What am I missing here?  What are my next steps?

  • Having the same issue...no entity is created to enable the Alarm Panel integration.  Have tried a bunch of things to no avail. 

  • Chris, I did figure this out - you have to create it manually.  Sadly, the documentation from either Konnected or Home Assistant is sorely lacking as far as getting the alarm up and working, and unfortunately it's a much more manual process than I thought it would be - nothing is really built into the alarm panel, and it needs HA or similar to actually function.


    I found this page which gave me a good start.  https://dfederm.com/setting-up-a-security-system-with-home-assistant/

  • nice - cheers.  I'll dive into it.  

  • Hi everyone, hopefully this is still an active thread.  I am somewhat stuck.  I followed the instruction at the above link and it was very detailed and helped me learn a lot.  


    However, when selecting the alarm card to add to lovelace, I get that red block error and in the entities section there are no entities listed.  


    What am I missing ?

  • Archie,


    Have you added the alarm configuration to your configuration.yaml file and restarted Home Assistant?  If so, you can post the yaml for the alarm and we can take a look.


    Also, you will need to make sure you have run through the configuration on the Konnected integration after you add it to HA.

  • Hi Mathew, I followed the directions in the link (from David) that were a good starting point.  I must admit my amateur approach to this, I'm not a coder and this all seems like rocket science to me.


    In the file I attached, is a powerpoint that outline what I've developed as follows:


    1.  Config.YAML - contains the original YAML config with a pointer (alarm: !include alarm_control_panel.yaml)

    2.   Alarm_control_panel.yaml - is the file that contains the base alarm function information (Alarm_control_panel_code.YAML)

    3.   Alarm_control_panel_code.YAML - Is the file that I think I should point to the Automations or maybe automations belong in the original config.yaml ?


    Starting with #3 I'm lost.  I've read through the Manual config in HA help and that just confused things a little bit more.  Although, I must say, at this point I understand what these files configs are doing (this is a huge milestone) I just don't know placement of how these files should really interact. 


    I know all of this stuff can be in the original config.yaml, but the there is a point where it becomes out of control so breaking it out like this makes sense.   


    Lastly:  that Alarm panel - Is the entity for that card the "alarm_control_panel.yaml" file ?


    Thanks for your help or guidance in the right direction.  I do feel I see the light and am somewhat understanding how YAML's work, although I need to overcome the block of where that info should reside.

    pptx
  • This looks pretty close.  The only issue I really see is in your code secret - this shouldn't go in configuration.yaml.  This should go in secrets.yaml.  In addition, you've got the parameter name broken up when it should all be together on a line like this (in secrets.yaml):


    alarm_control_panel_code: 1234


    After you make that change, restart Home Assistant.  Before you even try to add the card, go to your Entities list and search for "alarm".  It should pull up an entity named alarm_control_panel.alarm.  If you open it up and click on the details then you should be able to arm/disarm it.


    Then you can add the control panel in Lovelace.  You are getting the red box in the Alarm Panel Card Configuration because you haven't selected the alarm entity.  You should be able to pick alarm_control_panel.alarm from the dropdown, but if you don't see it readily then start typing and it should appear.


    Automations are completely separate from the control panel.  Get the control panel working first and then you can work on the automations.  You can actually configure them through the GUI instead of using YAML.  (I'm using Node Red for mine instead of Home Assistant)

  • Matthew - you are a badass!!!!


    First I want to thank you for taking your time to review this code and help me get this on track.  It works, I can get the card in Lovelace!  Too cool!

    However help me understand the problem I ran into and maybe I just did something incorrect:


    Working scenario:

       -  When I loaded my alarm config directly into config.yaml - it worked !  as below.


    # Configure a default setup of Home Assistant (frontend, api, etc)

    default_config:

    frontend:

      themes: !include_dir_merge_named themes

    # Text to speech

    tts:

      - platform: google_translate


    group: !include groups.yaml

    automation: !include automations.yaml

    script: !include scripts.yaml

    scene: !include scenes.yaml


    alarm_control_panel:

    - platform: manual

      name: Alarm

      code: !secret alarm_control_panel_code

    # Don't require the code to arm the alarm

      code_arm_required: false

    # Arm again after triggering

      disarm_after_trigger: false

    # Delay from arming and becoming armed, eg. to leave the house.

      arming_time: 120

    # Allow time to disarm the alarm before it triggers, eg. when arriving home

      delay_time: 120

    # Amount of time the alarm is triggered for

      trigger_time: 600

      disarmed:

    # Ensure the alarm can never be directly triggered when disarmed

        trigger_time: 0

      armed_home:

    # Leave no delay between arming -> armed

        arming_time: 0

    # Leave no delay between pending -> triggered

        delay_time: 0




    alarm_control_panel:

    - platform: manual

      name: Alarm

      code: !secret alarm_control_panel_code

    # Don't require the code to arm the alarm

      code_arm_required: false

    # Arm again after triggering

      disarm_after_trigger: false

    # Delay from arming and becoming armed, eg. to leave the house.

      arming_time: 120

    # Allow time to disarm the alarm before it triggers, eg. when arriving home

      delay_time: 120

    # Amount of time the alarm is triggered for

      trigger_time: 600

      disarmed:

    # Ensure the alarm can never be directly triggered when disarmed

        trigger_time: 0

      armed_home:

    # Leave no delay between arming -> armed

        arming_time: 0

    # Leave no delay between pending -> triggered

        delay_time: 0


    When I had this scenario:


    FILE:  Config.yaml


      -  Contained this line:

    alarm: !include alarm_control_panel.yaml


    FILE:  alarm_control_panel.yaml

    # Configure a default setup of Home Assistant (frontend, api, etc)

    default_config:

    frontend:

      themes: !include_dir_merge_named themes

    # Text to speech

    tts:

      - platform: google_translate


    group: !include groups.yaml

    automation: !include automations.yaml

    script: !include scripts.yaml

    scene: !include scenes.yaml

    #alarm: !include alarm_control_panel.yaml


    alarm_control_panel:

    - platform: manual

      name: Alarm

      code: !secret alarm_control_panel_code

    # Don't require the code to arm the alarm

      code_arm_required: false

    # Arm again after triggering

      disarm_after_trigger: false

    # Delay from arming and becoming armed, eg. to leave the house.

      arming_time: 120

    # Allow time to disarm the alarm before it triggers, eg. when arriving home

      delay_time: 120

    # Amount of time the alarm is triggered for

      trigger_time: 600

      disarmed:

    # Ensure the alarm can never be directly triggered when disarmed

        trigger_time: 0

      armed_home:

    # Leave no delay between arming -> armed

        arming_time: 0

    # Leave no delay between pending -> triggered

        delay_time: 0




    alarm_control_panel:

    - platform: manual

      name: Alarm

      code: !secret alarm_control_panel_code

    # Don't require the code to arm the alarm

      code_arm_required: false

    # Arm again after triggering

      disarm_after_trigger: false

    # Delay from arming and becoming armed, eg. to leave the house.

      arming_time: 120

    # Allow time to disarm the alarm before it triggers, eg. when arriving home

      delay_time: 120

    # Amount of time the alarm is triggered for

      trigger_time: 600

      disarmed:

    # Ensure the alarm can never be directly triggered when disarmed

        trigger_time: 0

      armed_home:

    # Leave no delay between arming -> armed

        arming_time: 0

    # Leave no delay between pending -> triggered

        delay_time: 0



    FILE:  Secrets.yamal

    alarm_control_panel_code:  ####


    This scenario returned error code of:  Component error:  alarm - Integration 'alarm' not found.

    no matter how I changed it, nothing worked.

  • Matthew, you are a genius!!!  Thank you - when I loaded that first part of the configuration for Alarm_control_panel in the configuration.yaml - everything snaped in place and worked.  


    When I clicked on "add card" in the Lovelace UI, alarm_panel was present.


    Selected it and baaaaam!

  • Is there a way to edit a post ?  Sorry that my last post blasted out like that, should have put it in a file.  If I can edit I'll take that approach.

  • I don't know if there is a way to edit a post or not.


    You only need to define the alarm in one place - either in configuration.yaml or a separate file.  If you have a line in configuration.yaml like this:

     

    alarm_control_panel: !include alarms.yaml

     

    That is simply telling HA that your alarm_control_panels are defined in alarms.yaml.  In this case, you would put the alarm panel definition in alarms.yaml, and do not need anything further in configuration.yaml.  alarms.yaml should contain ONLY the lines pertaining to the alarm, BUT your alarms.yaml must not have the initial line of  

    alarm_control_panel:

     in it or you will get an error because that specific line has already been defined in the base configuration.yaml.  So alarms.yaml has everything but that first line, and you need to make sure it is indented properly.


    The other option is to define everything in configuration.yaml, which is what your first case (the working case) is.


    So you need every line either in configuration.yaml or your alarms yaml file, but you can't have any line in both.

  • Matthew, I wish I could give you credits or something through this thing because most people just "don't" understand how important the term "plain spoken" language that makes all the difference.


    Truly thank you

  • Glad I could help Archie.

Login or Signup to post a comment