Answered

Very excited that version 1 is out


installed as per doco


discovery of my pro and wifi worked


added zones but no items show up in homebridge

Removed my hubitat plugin in homebridge, as I have konnected on hubitat.   still not working, should I remove the apps on the hubitat?


what else to should I try?


  • @David,

    1. Stop Homebridge.
    2. Remove the cachedAccessories file per the troubleshooting section on the GitHub repo page.
    3. Start Homebridge back up.

    Let me know if that fixes things.

  • Hi there I deleted the file as suggested. Restarted Homebridge No luck. I should mention when using the .5 version it did put the zones in Homebridge, but as they only showed them but did not function yet, all the zones showed as contacts only (as you said they would) I switched to Hubitat while you worked on this. Now, that half worked. Because I have one pro and one wifi, the first one I would install would fully function, but the 2nd, the hubitat konnected homebridge app would not properly subscribe the items. This seemed to perplex the developer When I saw your update I immediately jumped back. Anyway, did you perhaps want some logs?
  • @David,

    Thanks for the information. Since I've never used Hubitat in my development process, I would wager a guess that there's something still lingering in the setup with your panels.

    Your setup, as I understand your scenario, seems to have a "multiple personality" situation where it's mixing Homebridge accessories with Hubitat accessories, and maybe Homebridge is attempting to discover both panels and having an issue with those that are Hubitat? I'm grasping at straws here.

    Also, it sounds like you're not new to DIY and I can go out on a limb to ask you to attempt to flush any Hubitat-konnected devices from your Homebridge-Homekit completely and factory resetting both of your Konnected panels. As well remove any of Hubitat's attempted discovery.

    Removing the cachedAccessories file should have cleared up any problematic 0.0.5 -> 0.1.0 ghost accessories.

    Also could you provide some of the following details:

    • Attach Files:
      • Screenshots
      • Log Snapshot (txt file)
    • Homebridge System:
      • Node.js Version
      • NPM Version
      • Homebridge/HOOBS Version
      • Operating System: (Raspbian / Ubuntu / Debian / Windows / macOS / Docker)
      • Process Supervisor: (Docker / Systemd / init.d / pm2 / launchctl / hb-service / other / none)
    • Konnected Panel(s):
      • Panel Hardware Version
      • Firmware Version
      • Addon Panel(s)
      • Interface Panel(s)

    We'll get there, and I appreciate your detailed response, this is already very insightful!


  • There is a new beta version out, it doesn't show up as an update in homebridge/hoobs .. you have to manually install it.
    The following command will install it globally on the system:

    npm install -g homebridge-konnected@0.1.2-beta.0

    If you prefer to install it in a specific directory that you've navigated to, just perform the above command, without the '-g'.
    Feel free to install it and see if that helps.

  • Hello same problem here with 1.2 too

    Homebridge version 1.3.4

    Node Version 14.17.0

    Npm Version 6.14.13


    Os Linux (3.12.7)



  • I can’t be certain if you followed all of the steps David was told to perform. Also, please provide the details asked of him in my comment prior to the v0.1.2 install guide.

  • Yes I created a fresh home bridge install too with only the connected plugin

    (could be that I have connected the panel with Home assistant too?)


    • Homebridge System:
      • Node.js Version 14.17.0
      • NPM Version 6.14.13
      • Homebridge/HOOBS Version  1.3.4
      • Operating System: Docker
      • Process Supervisor: Docker
    • Konnected Panel(s):
      • Panel Hardware Version Konnected Pro / 1.2.4
      • Firmware Version  0.1.5-047de6
    the log says only: [Konnected] Listening for zone changes on 192.168.0.2 port 46827


    json
    (1.18 KB)
  • Thanks Michele,


    Looking at your config.json, the arming switch doesn't really do anything effective in v0.1.2-beta.0


    I would remove that


    Did you happen to register the pro panel with the Konnected mobile app to Home Assistant first? If so, then you may need to factory reset your Konnected panel, reinstall the latest firmware for the panel.


  • Hello, just to understand, the switch to activate the alarm is not working yet right? I'm using the stable version 0.1.2 not the beta, are there any differences?


    Yes I have registered the Konnected with the mobile app, so do I have to reset it? I would Luke to use home assistant and homebridge together.


  • The differences between v0.1.2-beta.0 and v0.1.2 can be seen here: https://github.com/konnected-io/homebridge-konnected/releases


    Both v0.1.2-beta.0 and stable v0.1.2 treat the arming switch as a standard switch and nothing else. Unless you want that to be an actuator switch, there's no real usefulness beyond just setting it to a regular switch.


    Registering the panel with the mobile app is fine, but inside the app, have you associated it with Home Assistant or any of the other controllers (like SmartThings or Hubitat)?


    At this point I would recommend not using the panel with more than one SmartHome Platform. That doesn't mean that you can't have Home Assistant control any other smarthome devices in your house, just not konnected.


    Using Homebridge and Home Assistant together on the device has not been tested and I don't plan to have any provisions to support both controlling the panel at the same time.

  • Ok understand so I have to flash the panel anyway right? Maybe the solution could be use mqtt to use both homeassistant and homebridge
  • Do you have Home Assistant hooked up to HomeKit?

  • Yes I have a raspberry with hassio and inside with portainer a docker with homebridge...only because the homebridge/homekit integration is better and more stable

  • Sorry, I think there was some confusion in my question. Are you using Home Assistant to add devices to HomeKit as well? (ignore Homebridge for the time being)