Getting Konnected working with Hubitat over Wifi Extender

Issue: Just fought this battle and thought I'd document and share the experience in case anyone else is having the issue in the future.  While switching platforms from Smartthings to Hubitat Elevation using this knowledgebase article: https://help.konnected.io/support/solutions/articles/32000024523-hubitat-install-konnected-apps 

 First order of business was to cut over the Konnected alarm panel interface kit which ties my wired alarm system into my home Wi-Fi.  This has been working fine with Smarthings over a Linksys Wireless Repeater (Separate SSID from main router).  Hubitat had major issues with this.  It would find the device while adding the user app during setup but none of the alarm sensors would work after setup and throw errors in the log files that the device cant be found.

Solution: Started with a clean Hubitat Baseline Configuration (rebooted the hub and didn't restore the config). Then reconfigured the Konnected device to join the primary network SSID.  In my case I had to bring it back to the other end of my house temporarily to get it in range of the main router.   I Ran through the install procedures again and it worked just fine and all contacts/sensors are working.  After this I reconfigured it once again back to the extended network (SSID_EXT).   It's been several hours now and the connectivity to the sensors seems stable.   Apparently the Layer2 MAC spoofing on the extended network doesn't allow for a clean app setup during initial configuration.

image



Login or Signup to post a comment