I hooked up an add-on board to my garage door switches to control my garage doors, but ever since doing so the lights on my garage opener are going off constantly.  I have a Marantec Opener and the switch is a board that has three buttons, one to lock the door, one to turn on the lights, and on to open/close.  Behind the switch is two terminals connected to the two wires that go straight to the opener.  I connected the wires from konnected to these same terminals.  


I have a feelings its  voltage issue or something. I am running konnected through home assistant, and have the opener zones configured as momentary switches with a low activation.  The garage switch terminals are pushing 12V dc from the opener, but I have diodes to block it from going to back to the add on board. Just not sure what is causing the switch to trigger the lights.  Do I need to use a relay?

  •  Were you able to resolve this? If so im curious how.


    I also have a Marantec garage door opener with the same wall switch. I used a relay from the konnected board to trip the door opener and noticed similar weirdness. The lights on the wall switch would go and it would go unresponsive until I triggered the relay twice. I think I resolved that issue by placing diodes on the two conductors that trip the door opener but am still testing.


    A new issue has cropped up for me and that is my garage door randomly opening in the middle of the night. I am also using HomeAssistant and from why I can tell from the HA logging, its probably not doing it. My best guess is the relay weirdness. Trying to figure out if any of the relay settings will help.

Login or Signup to post a comment