Solved

I've completed my install but I wanted to know if anyone has had any experience with the DSC 15W siren.  I can't seem to get it to work.  I don't know if mine was working prior to the install because I was on a 2 GIG wireless panel which used an integrated siren.  I've run a test on the wires and indeed there is a closed circuit.  Also the Konnected Board shows an amber light next to "Alarm".  I'd like to get some opinions before I go ahead and purchase a replacement siren as I'm not sure that is really the issue.


http://www.volutone.com/DSC-SD15W-15WATT-DUAL-TONE-SURFACE-MOUNT-SIREN-P16285.aspx


Any thoughts?

  • I was able to figure this out.


    1. On my siren, there was no need to use the communication wires, just the positive and negative.
    2. It made a difference on my siren which item was plugged into the positive and negative.

  • Joe — I also have a DSC SD 15w siren wired to my alarm main board which is not working. For some reason it has the red wire connected to a red and white wire pair and the black wire connected to a black and green wire pair. On my old alarm board the red/white wires were connected to the bell + terminal and the black/green wires were connected to the bell - terminal. I did the same with the wires on the Konnected alarm board. Are you saying I should only use the red and black wires?
  • Hi Shawn,


    Its been awhile but I believe that's true.  Do not use the green/white wire, only the red/black.  For the red/black it does matter which goes into the positive/negative terminal.


    I hope that helps.

Login or Signup to post a comment